1992 Crown Victoria LX running horribly

I have a 1992 Crown Vic, and im having problems with it. sometimes in the morning ill try to start it and it wont start, other times i get it started
and it takes it a long time before itlly pick up any power, like it wants to die and if i put the gas pedal to the floor it gives it a litlle power but backfires.. i have changed the fuel filter and cleaned the throttle body and it seems to be helping. i was wanting to know if anyone has these problems or knows what i should replace next?? it is just a good car and i dont wana get rid of it!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Crigdon wrote:

Change the plug wires.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
trainfan1 wrote:

And the IAC valve. See: http://www.lincolnsonline.com/tech/00017.html and: http://www.lincolnsonline.com/tech/00187.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

wires WILL.
How many miles on the plugs? Too wide a gap will eccentuate the wire problems
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
clare at snyder.on.ca wrote:

What about the MAF or moisture in the plug wells?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
F.H. wrote:

Part of changing the wires. Clean 'em out good before pulling the plugs if you're changing the plugs too.
Rob

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
trainfan1 wrote:

The only time my 4.6 ever backfired was when water leaked from the thermostat housing into a plug well. The leak was almost imperceptible.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Crigdon wrote:

Easy fix it Sharon Cooke is right. I second her suggestion.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Replace the plug wires and cap. Possibly the coil.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
getting it scanned for codes may help. the quicky parts stores do it for free i think.
http://www.minibite.com/america/malone.htm
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

    Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.