1993 3.8 taurus wagon. HELP !!!

As above 1993 3.8 wagon taurus. Starts fine then has a bit of a rough idle and smels like roten eggs..ad raw fuel. I unplug (te vacuum line on top)
fuel regulator and it smells beter and idles better. Is this the problem or what ?.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sorry for the spelling..keyboard is junk :).. Any help would be gladly appreciated

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Rotten egg smell, rough idle... how long has this been going on? How many miles? Maintained regularly? Sounds like the engine could be burning fuel overly rich. If it has been ignored for a little while your catalytic converter could be toast as well. Engine light blinking? Any codes?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
well no check engine light.. just bought the car. 147 kms spark were plugs gapped at 70 LMFAO. and just had a friend over and he took my rad cap off (while cold to see if the head gasket was going), and it was under pressure. HEAD GASKET might be going and might be all my problem. I have never had acar have pressure like this while cold. You ru nit for 20 secods and you have pressure like it was run hot for 40 min.. I don't know.. might scrap it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Probably....Bad fuel pressure reg, you already know where it is... did you notice it, the line, was wet with fuel?
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
that solves that problem, but what about the high pressure at the rad cap when cold ?.. Bad head gasket ?.. I drove it 50kms and thought the temp was around 1/2 to 3/4 ..it never over heated and seemed to run fine. Is the rad cap thing normal ?
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have it tested for hydrocarbons... usually pressure doesnt manifest because the system is supposed to be full of coolant up to the neck, all liquid.. no air.
Then pressure tested.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
test

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.