1993 Ford Ranger engine revs w/o gas pedal

Hi all,
I have a problem with my 1993 Ford Ranger. It stated about a week ago, the engine would idle at a very high RPM (3000 or so), but it would only do it sometimes. Also the engine would rev up to 3 or 4 thousand
RPM sometimes when i pushed in the clutch to change gears. Sometimes it would fall when i put it in gear, sometimes it would fall if I pushed in the gas. However, today really concerned me. Today while driving my truck, i pushed in the clutch to change gears and the engine quickly jumped up to 4000 RPM, then it fell to 2000, then back to 4000, then down to 2000 then up to 4 again. Then I put it into gear thinking that would make the problem go away, and instead my truck began to accelerate without me pushing in the gas pedal. As you can imagine this is very concerning.
Do you guys have any ideas as to what the problem may be, and how much it might cost to have it fixed?
Thanks in advance for your responses.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Throttle valve sticking ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
brianpkennedyut wrote:

had the same problem with my 02 (did i ever mention i hate rangers?) it was the throttle position sensor. Not sure if the 93's are the same as mine is, but that is what fixed mine. Identical symptoms... i just dealt with it until i got the parts... luckily i didn't have to wait long i found one in a junk yard off an 05.
Mine was an 02, 3.0L 5spd.
I almost guarantee this is your problem
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.