1993 Topaz Hesitation Problem ..

I have a small but frustrating problem with my wifes 93 topaz.
At highway speeds (90-100 km\h) the car periodically hesitates..
I have replace the wires, dist.cap, rotor button, fuel filter, and TPS (
Throttle postioning Sensor), the problem is a little than before but still there....
Any ideas ??
P.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did you replace the air filter, and spark plugs also? You could also try running a bottle of fuel injection cleaner through your gas tank.
Tim

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Need Stuff wrote:

is when power is really needed(more force on the engine).. i was doing some reading on the Throttle Position Sensor( i got a 93 taurus,simialar car)... on mine it is the a/c is also controlled by the TPS.... did you line it up correctly and check it out with a volt/ohm meter to see if there is any drop/spike in the electrical circuit when the TPS is moving throughout its range???? if you are not familar with this then go to www.autozone.com web site and look up Throttle Position Sensor and their How To replace, test, install it... about 6 pages and it gives some pretty good info on the TPS and how it operated... and this might be the culprit.. it seems to me that the TPS is most needed when accelerating (if its incorrect then the Oxygen sensor will take over from there and tell the fuel system to cut down or over compensate with the fuel, but only after you start moving...not when accelerating....... sounds like maybe your problem... might even be a loose wire or tarnish wire on the plug?????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fuel Pump? does it hesitates after a period of time driving? how long of a time? i have been told that ford fuel pumps well quite when hot. and then come back after sitting for while? or perhaps its the clutch? did you check all vacuum hoses? egr valve?
Need Stuff wrote:

-- friendbc AKA Beingsneaky Aka Sneaky_one http://geocities.com/beingsneaky/friendbc.html My Homepage http://geocities.com/beingsneaky/bridge_river.html Bridge River photos http://briefcase.yahoo.com/beingsneaky briefcase beingsneaky http://briefcase.yahoo.com/clao_raven briefcase clao raven http://briefcase.yahoo.com/bcsnukwa Bcsnukwa briefcase http://community.webshots.com/user/friendbc Webshots albums http://community.webshots.com/user/beingsneaky Webshots albums You're a stranger only once, then you're just strange.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
it really hesitates only only accerlation.... it doesn't seem to be a "x" minutes after running... just as you step down on the accelator to climg even a incline, it starts to hesitate or "miss"..
Paul.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
another thing too is.. you said you replaced the spark plugs but did you gap them? most spark plugs come gapped to .38 but the fords need to be gapped from .42 to .46. every car u have every bought the plugs were never gapped proper. check all emission sensors. plus look for a vacuum leak some where? maybe a vacuum hose came off some where?
Need Stuff wrote:

-- friendbc AKA Beingsneaky Aka Sneaky_one http://geocities.com/beingsneaky/friendbc.html My Homepage http://geocities.com/beingsneaky/bridge_river.html Bridge River photos http://briefcase.yahoo.com/beingsneaky briefcase beingsneaky http://briefcase.yahoo.com/clao_raven briefcase clao raven http://briefcase.yahoo.com/bcsnukwa Bcsnukwa briefcase http://community.webshots.com/user/friendbc Webshots albums http://community.webshots.com/user/beingsneaky Webshots albums You're a stranger only once, then you're just strange.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Need Stuff opined in

Okay.. I'm starting this thread over..Give us some more symptoms.
When you say "hesitate" that can mean anything from a couple hiccups from cylinder misses. To falling on its face and having to feather the throttle to get it to accelerate.
Which would you say is closer to fact?
If it accelerates better the more you push down, the problem is probably fuel mixture related. If not, probably ignition related.
Does it idle smooth and at normal speed when warm? Does it accelerate ok below 40 mph?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.