1995 Ford Contour GL (Misbehaving ATX)

Hi...
about 2-3 months ago, tranny stopped working. (wouldn't go in reverse, Drive, L2 or first.)
Wouldn't even let the car be backed up while in neutral.
We added about 2-3 quarts of ATX fluid, until it started working again, but was heavily slipping. Once I had it put to proper levels, it was fine until tonight. (Once I let it cool for about an hour tonight, I was able to limp back to the dealer, 1-2 miles away). Something sounded like a high pitched whine, as if something was freely spinning in it.
I personnaly think the tranny is about dead...
One of my uncles told me the fluid needs to be changed, it *might* be fine afterwards. (he told me that 2 weeks ago when I mentionned it started slipping a little again).
I seriously have doubts about that. (but it worked on his 1989 Corolla, it was slipping too)
I know ATX trannies are pressure / viscosity sensitive, but can it work?
(unfortunately, since it's at the stealership, it's probably gonna cost me a leg to find out)
OTOH, according to that dealer's website, I can get a 1998 SVT for about 10,000 CAD (little expensive, but those things are fun to drive :)
I honnestly don't know what to do... (I like the car, already had the engine swapped, and prefer the look of 95-96s, I don't really like the headlights on newer ones)
--

(\_ _/)
(='.'=) This is Bunny. Copy and paste bunny into your
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not sure from your posts if it's at dealer or not.
If the signs of slippage werent gradually apparent but sudden.. sounds like something broke.
If it were only slipping, I would suggest trying Lucas AT product.. worked for me.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@videotron.ca says...

Roughly how many miles/km's? I do know the ATX in the Contour/Mystique (I used to own a '95 Mercury Mystique LS with the V6) used an oddball trans fluid compared with most other Ford's.
--
If there is a no_junk in my address, please REMOVE it before replying!
All junk mail senders will be prosecuted to the fullest extent of the
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The engine has 185,000KMs on it (I assume the tranny has the same, they both came from the same car)
--

(\_ _/)
(='.'=) This is Bunny. Copy and paste bunny into your
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Comfirmed by Ford, the Tranny's dead.
So, 3 options...
1- Junk it 2- Have a used (scrapyard) tranny put in, it's gonna cost me around 850$ CAD 3- Rebuilt?
I've already sunk in more than 4K in a year in it (engine+tranny swap 6 months ago), about every sensor was changed with *NEW* parts.
rear shocks are ready to be done, it needs a new muffler and new tire (got a flat last week)
Otherwise, other than a blown A/C, everything is running fine.
Opinions?
--

(\_ _/)
(='.'=) This is Bunny. Copy and paste bunny into your
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.