1997 Ford Escort won't stay running

Car wouldn't start. Finally did but wouldn't stay running. PVC valve was burned and broken at connector. Changed valve, still won't run. Will start if pump the excellerator a lot but won't stay running. Makes noise
when trying to start and back fires. Any suggestions on what could be wrong. Need the car to get to work in the morning.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
possible air intake leak between mass airflow sensor and throttle body exhibits same symptoms. stuck open idle air control valve can cause inability to idle,popping may be a result of pumping accelerator pedal. then again may just be multiple engine ignition system misfire. hope this helps.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not sure what your post says. I understood the old cars (before electronic ignition, etc.). I'll ask my son. Thanks for the quick reply. I'll let you know if it helped....Judie
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Timing belt perhaps ?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
it sounds like the idle control valve which is situated in the inlet manifold
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
headlight bulb keeps blowing it does not blow a fuse ideas would be helpfull please
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.