1997 Ford Windstar major transmission problem

Ford Windstar 3.6 liter Towing Package 82000 miles
I have towed my boat before, but this time after about 100 miles, and a few hills but not a particularly hard run YET, the tranny started to slip.
Then really badly. I only ran maybe 1/8 after a mile and luckily pulled into a gas station with a big lot, thank God.
To my horror the fluid looked like it was streaming out of the front seal, but I could not see the seal because it is behind a shield, that the starter goes through. The fluid was coming out for quite a while, it was all underneath the length of the undercarriage.
I put a quart in to park and the tranny worked, but it all came out from the same spot in a steady stream, where the engine meets the tranny.
It was towed back, AAA Gold Rules, because it was 99 miles!!! So no charges but only tolls!
Put 7 quarts in yesterday, NO LEAKING AT ALL, and I drove it for several miles, shifting and no problems. Just wanted to see where it was coming from, but it kept taking it and did not leak! My background is a capable backyard mechanic not afraid to tackle any job. I have replaced tranny's on drive shaft vehicles no problem, but front wheel drive looks like a pain in the ass!
FORD GUYS PLEASE HELP!
WHAT COULD HAVE HAPPENED?
Thanks in advance. Joe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.