1998 Contour temp gauge

Hi all,
I have a '98 Contour with a temp gauge that works intermittently, but most of the time not working. Also the A/C doesn't work. I believe they both may
be a result of the same problem but don't know for sure. Any ideas what could be causing the problem, or what to troubleshoot?
Thanks in advance,
ZIB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
zib wrote:

answers from people with maybe the same problem who fixed it... year, engine size, automatic, standard trans. etc.. put down as much info as possible on the vehicle...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the sensor connection at the wiring harness for possible corrosion causing an intermittent gauge. When the gauge DOES work, does your A/C as well?
In some newer model vehicles, the A/C will shut off if the engine gets too hot. Same could apply in your case if the computer doesn't know the engine temp at all, and keeps the A/C off just in case the engine temp was critical and it didn't know it.
r/ -IanCT

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

harness for free due to recall) and my A/C quit working because the 'puter was thinking the coolant was -40 degrees and cuts off the compressor. May be the same thing?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.