1998 Ford Windstar Dies @ Idle in Gear

Please advise if anyone has a suggestion for the following problem:
We have a 1998 3.8 liter Ford Windstar. The engine was replaced two years ago at approx... 86,000 miles and we currently have 124,000. The engine was
replaced with a FQR engine.(Ford Quality Re-manufactured engine)
I put new plug wires on at the time of engine replacement and it had new plugs. I have also just replaced the plug wires again at 122,000 miles.
The engine will start and run without missing if you are in neutral. This is an automatic transmission. If you put it in gear and sit at idle, which is 750 RPM, it will drop at random from 750 RPM to 500 RPM at times and may die. If you just touch the accelerator with some additional gas and maintain the RPM at 750 it will never die.
Has anyone had this problem and if so what was the problem?
Thanks in advance!
PEB 740-332-1104
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think this is the most common problem I see on this message board with the Windstars, mine does it a little differently and its random, I tested and cleaned the IAC, hopefully that will fix it, not sure yet because it only happens to me randomly

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.