1998 Mercury Grand Marquis 4.6L Txt more readable

Sorry about my initial post...hopefully this is more readable
Need some advice:
Bought the Mercury GM new and have kept up the maintenance. Got a nagging
problem that seems to be getting worse byt he day. The engine light keeps coming on and then going off for a while. All fluids and temp remain normal but have a real erratic idle especially when cold. 6 months ago I took it to a local shop and he cleaned the throttle body and the surrounding area and I think he replaced the idle air control valve...kind of worked...no more engine light( until now) but from time to time I got the erratic idle especially when cold. The scan tool says P1507 and as of late P156. P1507 puts me back in the idle control valve area and throttle body...the P156 says it a oxygen sensor rear passenger....may be the effect of the P1507 problem. At this point, I just don't know and was hoping someone out there may have seen this type of problem before. Also the car has been great and now has 148k on the speedometer and consistency get 20 miles a gallon. Appreciate any advice
thank you Lee
-------- Binary Usenet downloading made easy =--------- -= Get GrabIt for free from http://www.shemes.com/ =-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You need a proper diagnosis; scan tool readings are meaningless without the manuals and the knowledge to interpret them. As I posted earlier, unless there is a strong reason not to return to the shop that first looked at the concern, you should go back there. Otherwise, I would recommend a Ford or LM dealer.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.