1999 Escort ZX2 timing belts.

We had a belt go out at 77,000 mi. It was at freeway speeds and by the time we got off the freeway, the engine was shattered. I had it professionaly rebuilt, by a shop I had used numerous times over the
years. After 20,000, miles there was belt trouble again, and the valve regulator ???, was fixed, by Ford, for $1700. 17,000 mi later, the belt idler bracket broke off, the front of the motor, $1300. Yesterday ( 12,600 mi.later) the belt popped off. I'm having it towed in today to analyze. This vehicle, since day one has been my wife's commuter. She goes 58 miles a day 5 days a week on the freeway. That's pretty much it. We live at 100 feet above sea level, and her job is at 1700 foot level. I had one guy tell me it was cause of the climb everyday. Also, this car has never idled smoothly. I was told that that was due to the dual overhead cam? I have stopped and asked other ZX2 owners, and they say the same thing. One lady said her husband was a mechanic at a Ford dealer, and he could not smooth out her ZX2?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 24 Jan 2012 07:20:34 -0800 (PST), snipped-for-privacy@sbcglobal.net wrote:

My brother and his kids have all driven escorts and ZX3s. 4 or 5 ZX 3s over the last several years - with NO engine problems - and my nephew pounds the living crap out of his. Automatics do have a bit of a quivver at idle in gear - but less than my PT Cruiser.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.