1999 Ford Explorer Timing

[Question for anyone!!
My boyfriend took his Explorer in today as he has been having problems with it not runnung well...hesitating...sputtering etc.
We first had the spark plugs and wires done (his check engine light has been on) also had some gasket cover done...sorry dont know the correct one but I know it was not the head gasket.
Now after today, they said he needed the coil pack and timing done!!!
This is a 1999 Ford Explorer with about 79,000 miles!! Does that seem right. He is very picky about oil changes and etc.
Any opinions would be helpful...They also said it would run about $1100.00 to fix. This is a Ford dealer we took it to also.
Thanks!!
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

sounds right ford is crap especially the 4 liter
crap crap crap
btw are you a fox ?
hurc ast
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
x-no-archive: yes
The 4.0 is a pretty dependable motor.... Early on they did have some tetthing problems but most seem to like their Explorers.
It's pretty hard to judge whether a diagnosis is appropraite without knowing something about symptoms and if any codes were retrieved.
There are other, more common problems rather than the ones you mention that may cause some running concerns. $1100 sounds a little spendy even by dealership standards.

http://www.autoforumz.com/Ford-Mecury-1999-Explorer-Timing-ftopict110724.html
http://www.autoforumz.com/eform.php?pQ9156
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 05 Apr 2005 07:09:16 GMT, "Jim Warman"

lmfao really forget the timing chain issue did yay jim

jim it sounds like like a skipped tooth on a timing chain
lmfao u go girl

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

I actually agree with Jim here. Unless we know the codes and other symptoms, it is hard to offer advice.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

lmfao you arent even a tech ever work on a 4 l better check those tsbs lmfao all of them timing chain
hahahaha
hurc ast
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.