1999 Ford Windstar Front Electronic Module replace/repair?

A friend's 1999 Ford Windstar started to cause trouble a year ago: The right front turn indicator went on once, then off and a problem with the bulb was displayed, even though it was ok. Connecting front and side
indicator lamp "solved" the problem. Later more electric devices, all controlled by this "FEM" went "mad": Interior lights flashed, windscreen wiper turned on and off randomly, theft protection sounded alarm without a cause.
Almost all 2pin SMD-Components are slightly misplaced, probably causing bad soldering: (
http://www.falk-willberg.de/Windstar/FEM-1.jpeg ).
While removing the FEM from the car, the interior lights started flashing. It stopped, when I knocked on the Module...
I would prefer to get a "FEM" from a junkyard, but the Ford dealer says, that the module must be "clear", because otherwise the central computer would refuse to communicate with the module. Any way to "clear" the module or purchase one that could be used?
I could re-solder bad junctions, if I had an idea, where to start (I don't want to do all of them).
Grateful for any advice, Falk P.S.: Asked in s.e.repair b4, but hoping to get more help here.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.