2001 Ford escape problems with jiggling, jiumping and acceleration

I have a 2001 Ford Escape with about 89k miles on it. Recently when i turn the car on when it is cold, it starts shaking and "jumping" like if the
engine dosent havve enough power. When I tap the gas, it goes back to normal but then 2 seconds later it starts again. I took it to a mechanic and he changed the fuel filter thinking this would help the problem, but it didn't. Also the car accelerated 2 times while in Park and without me stepping on the gas, when i chagend the gear to Drive it stopped, but when i put back in Park it started again, also when I changed the gear to Reverse it accelarated with a little bit of force. Wht do you guys think I should do? Additional Details
the mechanic did find a tear in the vaccum hose and replaced with temporary flexible one, he did mention to try and buy the original hose the one that is more harder to flattened out because of the vaccum, and yes the check engine light is on
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
<...>

You're going backwards. Find out what the trouble codes for the check engine light, and fix those.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.