2002 escort ignition. 1 cylinder firing

I have a 2002 escort. Started to run rough and stopped running within 2-3 minutes. Was able to start and run for a few minutes with no power, Currently it does not start, Cranks good and appears to be getting gas.
Upon testing spark plugs with a tester between plug and wires, I am only firing on the #4 cylinder. Spark plugs and coil have been replaced. Any ideas on what may cause it to fire on only 1 cylinder?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have to ask what kind of spark tester you are using.... the ones that look like a spark plug without a ground electrode but with clip on the side are notoriously unreliable....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The tester has a spark plug boot at one end and the other end of the wire looks like the end of the spark plug so the car wire attaches to it. There is light in the center that lights. I attached it to each spark plug at least three times and always got the same result. The light flashes on the #4 cylinder and does not light on the other three.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm still unsure of the tester that you are using.... if this is a neon liht tester, I haven't had good luck with these either.... Is this an SPI or a Zetec? I'm not as familiar with cars as I could be but I'll help however I can.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check the spark plug wires.how does it appear to be getting gas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.