2005 Escape Fuel Problem (no check engine light yet)

My 2005 Escape is starting to give me trouble after 5 years (44k miles) . I recently noticed very poor fuel economy and soemtimes difficult to start. My wife noticed that when she started the engine,
the low fuel alarm went off when she had 3/4 tank of gas. after a few seconds, the fuel gauge started to climb and then it was okay. I was thinking that maybe I have a tank of bad fuel (maybe water in it?). The check engine light hasn't come on. Would the light turn on if ther was an engine code?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fuel economy could be many things. Borrow a OBDII reader to see what codes may be set. My recent experience with the fuel gauge in a 2001 Escape going erratic like yours was bad: the fuel pump died a few days later. Replacement is easy - a hatch under the left rear set. The part however is pricey. Plus, when mine failed I was miles from home. I don't know how to test for an impending failure so I can't suggest a way to confirm this is your issue. The sender unit and pump are one unit so it is not unlikely to be some linkage. God luck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Call the dealer. I vaguely recall something about collapsing fuel filler necks, or something in the 2005 Escapes. There should be a TSB that the dealer can reference from your VIN.
--
Clarence A Dold - Hidden Valley Lake, CA, USA GPS: 38.8,-122.5

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.