'65 Mustang new radio problem

Hi everyone,
I installed a new AM/FM cassette radio in my '65 Mustang last spring.
I got everything installed correctly with the exception of the radio's
presets.
Every time the car is turned off, I lose my station setting.
I haven't set the clock either because it only reverts to 12:00 every time.
I tried using an eyelet connector to attach the trickle feed wire to the back of the cigarette lighter. The lighter is working, I would have hoped the power there would have fed the radio presets.
I know of one alternative - feeding a wire to the starter solenoid. However, the wire lead does not have an inline fuse. I could attach one to the feed wire but I'd rather find an under-the-dash cure first.
Any help would be appreciated! Please post replies hear, thanks!
Andrew Croft
'65 Caspian blue 6 cylinder coupe, blue interior [07.85 to present]
http://www.inhouseproductions.on.ca/Mustang.jpg
'96 Forest green GT coupe, grey interior [04.96 to 04.00] '88 medium blue 5.0LX hatchback, grey interior [93-04.96] '80 white hatchback, red interior [91-93] My other car is a Ford - '04 Escape, 6 cylinder, silver, grey cloth - LOVE IT - it's my second Escape.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Usually both power wires are fused. Are you sure you have the right wire?
--
Every day is a good day- it's just that some are better than others.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.