87 ranger fuel problems

Would the injectors fuel pump/filter cause the truck to not want to start? Or maybe die out? I know it's not the starter, alt or battery, but the truck
is hard to start sometimes.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Be more specific, please.
"Doctor, sometimes when I wake up, I dont feel good.. what's wrong with me?"
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what it seems to me is, that when I go to crank the truck in the morning, it feels like it is not getting any fuel. I put some injector cleaner in the gas and it seemed to help a little. But occasionally it will die while I'm driving it.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What do you mean "it feels like it is not getting any fuel"?
"feels like"???
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

"Doctor, It feels like I'm still tired.. sorta"
What Engine?!
Does pumping the gas pedal while starting help? Computer sends more gas
Flooring it? Computer sends less gas
What are the rpm's first started? when warm? Does the engine speed 'hunt' in park or at stop?
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jmvikings wrote:

by the way if you have to ask about the fuel filter its time to change it. Yes injectors could cause it as can a worn fuel pump and many other things..
1: change fuel filter 2: check fuel pressure 3: does it hold fuel pressure after engine has been shut off? 4: hows timing set 5: tuneup? plugs ok? cap, rotor etc?
ALWAYS TRY THE BASICS FIRST
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for your response.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.