'88 Ford Taurus chk eng light problem

I have noticed lately when I come to a stop and let it idle, it idles very high. I also have a problem when I am going about 30+ mph. I accelerate
up to speed, let off the pedal and start coasting. Then when I push on the pedal again to accelerate more, my check engine light comes on for about 1-2 seconds, then goes off. During that time period, it seems like the engine is dying. I was thinking it could be an oxygen sensor, but i am not sure. It seems to be a problem when the vehicle is running around speeds where the gears would shift. What do u guys think?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In article
snipped-for-privacy@yahoo.com says...

What are the codes?
--
I. Care
Address fake until the SPAM goes away ;-}
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
says...

I think the light is coming on because the engine dies, just like the light comes on when you shut off the engine. So the light coming on for a second or two doesn't mean that there is a diagnostic code. If hte light were always on, then I would think there has to be a code. However, there can still be helpful diagnostic codes even if the check engine light is not alway on.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.