89 E150 Idle problems

Hi, I have an 89' Econoline E150 with a 5.0L V8. I took this off the road sometime back and would start it up every now and then just to let the engine run. Sometime during this period something happened and now the van
won't keep idle. It'll start and run so long as you give it a lil gas but if you let off it dies. Any ideas? Thanks!
-Ryan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 29 Oct 2005 00:00:15 GMT, Ryan Stalter

Yo! Clean tha IAC. It is best to remove it from the side of the throttle body. Let the valve end soak for a while in throttle body or carb cleaner. You may need a small brush to help clean it. A good aerosol throttle body cleaner should be used to clean the inside bore of the throttle body while you are at it. Might not fix it but, it's a cheap way to start and has a good chance of doing the job.
Lugnut
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
you could pull a plug or 2 and check for carbon buildup.how old is the gas.how full was the tank.could have water in it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Also check your PCV ...
--
Hooter
------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.