'91 Cougar with no heat

I have a '91 Cougar that has intermittent heat in which I already had the thermostat changed but does the same thing.
What happens is that when I go to defrost the car in the morning, no heat
will come out and the temperature gauge goes almost 3/4 up without going in the red zone, and sits there for a while and still no heat. Then the gauge goes down and heat comes out. This happens on and off. I had the thermostat changed and it worked for about 1000 miles and now it is doing the same thing.
Any Ideas Thanks in advance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Something in the heater core is stopping it up.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
you did not say what motor you have ,but I will give this a shot anyway. if you have a 5.0 V8 , your coolant is probably low. if you have a 3.8 V6 ,you probably have a blown head gasket

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It looks like your coolant level is too low and/or an airpocket in the heater system. Typical symptom: temp gauge reading high and no heat from heater/defroster. Still check thermostat, poss repl. again. Good luck!
bones wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.