91 Taurus wagon

Ive got a 91 taurus witht he 3.0 V6. It runs good, gets decent mileage but it just dosent have any balls. Its got 165k miles on it. strong tranny, however has a small thump everyonce ant a while
when shifting from reverse to park to drive. Any idea's?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mat wrote:

back and forth.... open the hood and shift from park, drive, reverse with your foot on the brake and you can see the engine move.. probably your problem....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mat wrote:

Your 3.0 is young, yet, with a good long life ahead of it. For poor power, change the fuel filters, check the fuel regulator & fuel pump output with a pressure gauge on the Schrader at the fuel rail. You are right in the age/mileage range when these problems will start to show up when all else has been addressed (common tune-up & maint. items).
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Wow! I didn't know 91 Tauruses existed with Strong Trannies.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mine must be an abnormallity.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.