92 Ford Taurus LE

I have a 92 Ford Taurus 3.0 6Cyl. I can drive it until it gets hot and then it doesn't want to go in drive if i stop at a stop sign or light. If I put
it in netural and back in drive it will go until I have to stop again.As long as I'm on the high way I have no problem only when I have to stop.Can someone give me an idea. Thank you
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check your transmission fluid, better yet.. have it serviced. Hope you are low on fluid, that's an ominous sign.
Yes the AT Dipstick is very hard to find between the engine and firewall angled to driver's side.
Check hot, running in Park.. should be clear and not smell 'burnt' DO NOT OVERFILL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had my transmission fluid changed about two months before my car started messing up the fluid level is ok I always check my oil Transmission brake fluids and radiator twice a week no problems there. Thanks for your suggestions do you have anymore
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'm not trans mechanic, so take this for what it's worth. :-)
IIRC 1992 was the first year that the transaxle on the Taurus was electronically controlled. Have you checked the engine codes? Something like a Manual Lever Position Switch (formerly known as a neutral switch, or backup light switch) could perhaps cause that. I do know that some sensor/switch malfunctions will show up on an engine code scan. It's worth a try.
CJB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.