93 aureostoar odd shifting.??

Hello there i have 93 ford aerostar electronic 4wd , i just changed the trans but for some reason when i put it in gear...i have to give it some gas for the gear to kick in....then works perfect, but when i stop
at idle it kicks out of gear...give it gas and boom back in it goes???would it be the fluid pump?? please help greatly apreciate it!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wes snipped-for-privacy@hotmail.com wrote:

Just general advice: recheck fluid level hot, in park.
vac. modulator... proper install? thee's a 'pin' goes inside it... did you have it installed right?
MLPS switch install properly?
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check, check, check, and check......still acting up... hmm any other advice?? i mean it work when your driveing just when u stop and the switch does work, because when i put in gear, idle goes up but not high enough to kick in gear i have to step on the gas tehn kicks in and goes...but its to hard on the tranny dont wanna keep on doing that....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
. . =====wes snipped-for-privacy@hotmail.com wrote:

====== Call whoever you got the used tranny from and tell them you don't apreciate the fact that you spent your time installing a bad trans.
or........... drop 2 quarts of fluid in it and see what happens, disregard the dipstick reading.
If the thing shifts okay once it engages in gear and the fluid isn't low....... you need to have it worked on by a technician. Because you can't fix it without taking a huge crap of a chance that you'll fubar something else up in the process.
My definition of "shifts okay" = nothing weird going on.
~:~ MarshMonster ~:~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.