93 Crown Vic 4.6L

I appreciate anyones advice.
Engine hesitates when punshing the gas, and power is slugish. New plugs,wires,dist cap,air filter already done. AND..........if I unplug the MAF (mass air flow sensor) the engine stalls
after reving it....so I guess it's working properly.
BUT.... if I take the whole plastic air intake compartment out........I get immediate engine response and no hesitation but stalls of course after reving it up. I'm sure its another stupid sensor or a vacuum problem...but I need more info.
???? Anyone????
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is there any way that air flow is constricted to the plastic air intake? I'd also check the throttle position sensor for the stalling thing.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Possibilities, is EGR passage way clear?, common problem to get stopped up, same on mine, also, there is a bypass hose that runs from air intake tube(between air filter and throtle body, but closer to throtle body, about 1" dia.) to rear top(downward and to the back) of manifold area, hard as heck to change , had same problem on mine. any codes displayed? JR
Jean wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.