'93 Escort 1.9L Idling problem

I have the above car with about 65K on it. As of late when it the engine idles it starts to sound as if it is going to stall (but it never does). If I turn on the air conditioner (which brings the idle higher) it will stop
doing it, and as soon as I accelerate it goes away. It has been in an area where it is subject to dust (if that brings any ideas). Any help is appricated (poor college kid here) and I would like to repair this myself if I can figure out what the problem is.
Josh
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for everyones help. I was leaning over the engine today and heard a hissing sound. Further inspection pointed the the PCV connector elbow. Age/wear had created a slight bend in the connector, which eventually formed a hole.
Thanks, Josh

If
if
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 16 Jul 2003 17:11:42 GMT, "Josh Thomson"
Leading into the 'carb' from the breather assembly... is a box that has two tamper proof torx bolts holding a lid. Inside is the sensing unit for air to fuel ratio mixing.. over time these wires get gummed up and need cleaning/replacement. They will cause the car to intermittently have erratic idle and/or highway operation. Start there...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.