93 Taurs cruse control

My cruse control just stopped working about a week ago and I was told at the dealers that I needed a speed control modulator. I was told it was located up under the dash. I looked for something (Unknown to me)
that looked like it might attach to the cruse control and didn't see anything. I have a totaled 92 Taurus behind my barn I was thinking of using this part from it if only I know what and where to look for it. Does anyone have any idear about what I am looking for to fix this cruse control problem?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ford Man wrote:

The speed control amplifier is located on the LH side of the instrument panel behind the lamp dimmer potentiometer. (electrical module)
When did it quit and how? Is the trannie shifting funny now? I would be more inclined to suspect the VSS on the trannie.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Bob Thanks, I just took off the wrong part it appears. Tomorrow night I will look on the left side of the steering column and from what you say I should find the amplifier. The rest of the shifting is working excelent, I have already replaced the VSS on the trannie because it starteds shifting funny too. Now just the cruse will not work.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.