94 Escort fuel pump Help Please!!

After a short freeway run my escort died while coasting thru underpass. I thought it might be bad battery terminals (had a problem with that a few weeks ago) Cleaned them and tried to start but no go, even with a jump. Had
it towed home and put a full charge on it (battery was completely dead) Tried to start after charge and engine will barely turn over, had the battery checked and it s good. Didn't notice warning light on dash , one I haven seen before "FUEL CUTOUT". I checked the fuel cutoff switch in the rear passenger side speaker well and I think it's working alright. I've checked all the fuses and they're good. Am I looking at a bad fuel pump? Please any help or ideas would be greatly appreciated...Thank you.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jettparts opined in

You get the prize for stringing together the most imaginative set of unrelated symptoms i have seen in the last year.
Total wiring screw up, is the only thing I can think of that would fit all that together. A test light at all the connections and check grounds..
Do you HEAR the fuel pump when you sw ignition on? may need a helper while you get close to tank.
You check the cut-out by thumping it firmly with your fist then resetting the button.
--
- Yes, I'm a crusty old geezer curmudgeon.. deal with it! -

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.