94' ranger problem

i have a 94 ranger 4x2 with 150k miles...regular tune-ups(plugs, oil and filter) its always been cold natured, not wanting to stay running in winter till it warms up.
but its been doing it all summer and not just while warming up. revs low then back up. A/C makes it worse..rotorand cap look good, plugs are gapped within specs.. i was thinking the choke...cant afford to be wrong though HELP! thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Link opined in

Oh my! I think, if you're going to work on this vehicle, you had better learn how its systems operate.
First, the fact it's a 4x2 means nothing... you didnt include what engine.
Second there's no "choke"
Go to the library and find book on Ford or Bosch FI systems by Charles O Probst:
http://www.fetchbook.info/search_Charles_O._Probst/searchBy_Author.html
Read it thoroughly
Now go to google and search this group on your problem..
In point of fact, your intuition may be right in that the problem is at the throttle area.
Main suspect: the Idle Air Bypass or Idle Speed Control mechanism (same thing) dirty/sticking
1. NEVER adjust throttle stop screw except as absolute last resort
2. NEVER use CHOKE cleaner.. look for product that says it's safe for FI and electronics.
At least get a Haynes book on the vehicle, you cant afford to NOT have a reference.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had no idea the it dosent have a choke! sorry about the engine...its a 3.0L the cleaner you suggest, is it an electrical contact cleaner? thanks
On Mon, 04 Oct 2004 12:27:36 GMT, Backyard Mechanic

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Link opined in

Could be... the key is it is safe for FI engines.. ask parts counter guy.
Get the book, at least. before you start
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 05 Oct 2004 13:18:56 GMT, Backyard Mechanic

thanks for your help
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.