94 taurus /EEC Fuse

1994 Taurus gl 3.0 blows 30amp EEC fuse Anybody know were were I could start looking to find short?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
PAUL5SAN opined in

WHEN does it blow it?
Exactly
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
blows fuse when driving up hill with in a half mile had idling in driveway for over an hour with no problem . noisey fuel pump in tank at times .idles smooth
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
PAUL5SAN opined in

tough one... follow big harness, rap and tug
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Backyard Mechanic wrote:

Once i junked one and was taking parts off. I took the air box plumbing off and was working on the drivers side of the engine. The big harness going across the top Left of the engine had rubbed and bare wires were exposed. You could not see this without de layering a bunch of stuff. You had to pull the harness up to see it.
Good luck.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BOB URZ opined in

So... if you hold the brakes, in drive, and rev engine and it blows...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It Was Big Harness that ran behind motor original staps broke and harness was against exhaust. runs great had several frayed wires and 2 that were burnt threw now the ck engine lite is on I thought it would go out after we fixed problem and had battery disconnected .
Thanks all for your help Evevery one seem to be right
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
PAUL5SAN opined in

is it ALWAYS on or sometimes?
go to autozone have codes read and come back..
DONT change ego sensors if ref comes up till you come back.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
codes 12,21,33 lite is on steady after a minute running. took off egr vaccum tested /worked found cracked vaccum hose today we replaced frame bushings sinnce there were none.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.