94 Taurus turn indicator going bonkers!

this newsgroup has solved many of the odd things that seem to affect the 94 Taurus wagon.
The left turn indicator on the dashboard goes at a normal speed. The
right one is clicking away at a serious clip! Anyone had this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 24 Feb 2004 00:46:14 GMT, snipped-for-privacy@hotmail.com (John) wrote:
|this newsgroup has solved many of the odd things that seem to affect |the 94 Taurus wagon. | |The left turn indicator on the dashboard goes at a normal speed. The |right one is clicking away at a serious clip! Anyone had this?
burned out turn signal bulb ! go outside the car and see for yourself.
Lg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bad bulb

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thomas Moats wrote:

Look at the bulb carefully. I assume its in the rear. What i have had happen to mine is a bad socket. The bulb connections oxidize and melt into the bulb mount plastic. A new bulb will work for awhile, then quit. You take the bulb out and the filaments look OK, but the connections look cruddy. Look over the socket carefully. Replace it if it looks bad.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.