95 Merc

I have a 95 Mercury Grand Marquies and its been givin me some guff. The car has a major wiring problem and i have not been able to locate the source of the problem. The car wont run anymore, but when it did
if you hit the brakes the car would die. Same goes for the power windows its like somone just turned off the key. I have checked with the local napa and they hevent a clue so i turn to the combined wisdom of everyone who cares to comment. Thanks a lot your help is greatly appriciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Start at the alternator and LOOK at each connection back to the battery. Take them apart if you must. Then check the frame, body and engine grounds the same way. It sounds like you are taking power away from the fuel pump or computer with those loads. Then you get to follow the hot wire back from the battery or junction to the main fuse bank. It is a tedious process, I know. That is why a former employer put up with my crap. Look for damage insulation, or any wire that looks or feels odd. A quick overview before you start the detail work may help. Do the Grounds first, they are shorter and easier to deal with. just loosen and clean and reconnect. You'll find it eventually.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.