'95 Sable: "Trans Control Piston" & Lucas Trans Fix ?

Hello:
Have a '95 mercury sable with about 80,000 miles on it.
Have a bit of a transmission problem, I think.
Occasionally, when in DRIVE, from starting out, or already in motion,
pressing on the accelerator does nothing. Engine runs fine, but apparently disconnected from transmission and/or drive wheels.
Has been diognosed as a broken (or stuck ?) "control piston" in the transmission, and that I should try adding Lucas Transmission Fix fluid to the transmission oil.
Also have been told that Ford changed this "control piston" from steel to Aluminum that year to save a few pennies, and hence the problems.
My question are;
a. what is this control piston ?
-does this sound like the likely cause ?
b. worth trying this Lucas product. ?
c. worth trying anything else ?
Much thanks, Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi, Thanks for help; appreciate it.
What might you suggest for my apparently cracked accumulator piston ?
Does the "whole" transmission have to be taken off and "re-built" ?
Thanks, Bob -------------------------

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bob wrote:

Since it has to come out of the car and disassembled, yes. Be prepared to pony up $2000 or so (give or take a few hundred).
BOB

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.