96' Explorer power locks continuously try to unlock!

Hi...
My 96 explorer has been acting a bit weird lately... started out with the power locks only unlocking and not locking except for the rear hatch. It would still power lock all the doors. Then the interior
light would not turn on with the opening of any door. These problems are a nuisance but still manageable until I have more time to figure them out! But last weekend my headlights would not shut off and then this week my power locks would continuously keep unlocking almost as if you were holding the button down.
Well I figured out the headlight problem it was caused by a poor ground, but my powerlocks still have a problem if I try to manually lock any door by pushing the lock "plunger" down it begins this continuous unlock "loop". I have now figured out that I can stop this by holding the power lock button on lock for ten seconds or so, but essentially I can't lock my doors!!!
Does anybody have any ideas? I'm guessing some type of short in one of my doors and I guess that's where I'll start this weekend, but any suggestions would to narrow down my search would be greatly appreciated!!!
Thanks in advance!
J
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.