96 ford contour problem

sorry if this is confusing at all, i just woke up and im kinda groggy yet. Our 96 contour has a problem where it wont start sometimes. heres the
deal, I replaced the motor last year with a very low mileage one after the original one crapped out. Ever since replacing the motor, there would be a really bad idle which ended up being that the throttle cable would bind and the throttle would stick, if I twist the cable, the idle would go back to normal and the cable wouldnt bind. After finally getting the cable in a position that it wont bind as much, other idle and running problems started. I replaced the plugs and wires with oem ones and replaced the pcv valve. I then found that the engine wouldnt start and had no spark at all, it turned out that id broken the end off of the crank position sensor when i replaced the pcv valve. heres my main problem, every now and then, the car wont start and has no spark. Sometimes even after it starts and i go somewhere and shut it off for just a few minutes it wont start. i have to wait anywhere between a few minutes to several hours before it will even fire up. could it still have something to do with the crank position sensor? There seemed to be an elongated mounting hole in the sensor, does the sensor have to be aligned a certain way? ie twisted one way or the other? it doesnt seem to twist back and forth at all when i loosen the mounting screw though. or could something else be causing it? I also replaced the coil pack with a known good one to rule out the coils crapping out this is mainly my wifes car and she now refuses to drive it because shes afraid it wont start for her
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
also, the check engine light has never come on and no error codes are stored

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
inspect your wiring harnesses.contours have a major problem with the wire covering hardening and breaking causing wires to contact one another.there has been a recall for vehicles up to ten years old or one hundred thousand miles.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Also, look here: www.contour.org
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like a faulty ignition module switch. a very easy fix, but about $55 part. get yourself a haynes manual for the contour and it will tell you exactly how to change it. I got my manual and my switch at Autozone. good luck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.