96 Taurus-- No Acceleration When Turning

My car will not accelerate when Im turning left--the engine only revs. Once I straighten the wheel, acceleration is normal. I feel the car jerk once the wheel is straightened if my foot is still on the
accelerator. It feels like something is disengaged when the steering wheel is turned and then engages when it is straightened again. This only happens with left turns. Thanks for any help you can give.
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It might have something to do with the axel that connects the transmission to the wheels. You need to take this to a mechanic right away. This is potentially very dangerous.
jeff

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Assuming you have an automatic transmission, check the AT fluid level with the car in Park using the AT dipstick. There's a good chance the fluid level is very low and you're sucking air instead of fluid on left turns
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.