97 ford expedition rear antilock brake contrl

do anyone tell me where the rabs control unit is and how to find wiring to it.This 97 expedition xlt is always having a electrical problem.the fuse to brake light kept blowing.i jump wire around anti brake lock system and
now the brake light works and also the interlock for park works. BUT i'm concern about anti lock brakes not working. any body with knowledge on this ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'd suggest joing the Expedition Owners Group Mailing list and asking the question to that group - see http://mail.xpog.com/mailman/listinfo/expedition . Asking in the forms at www.flatratetech.com is also a good idea.
A 1997 Expedition has 4 wheel ABS, not rear wheel abs.
I would GUESS your control module is bad, although it is possible you have a pinched wire that has shorted to ground. The control module is attached to the ABS pump
www.directfordparts.com will sell you a new control module for around $211. However, the Ford Shop manual talks about programming the unit with vehicle specific data. This might mean you cannot do it yourself. This is definitely a question for the techs at www.flatratetech.com .
This is a job probably best left to your Ford dealer or a competent independent garage (not Midas).
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.