97 taurus idle?

hi, we have a 97 ford taurus 3.0/vulcan, and when you start the car, the idle sometimes shoots up, or sometimes it will shoot up when u just park it
and let it sit, but sometimes it idles just fine
any idea what this could be? thanks. :)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
nobody important opined in

are there any other issues?... like when you slow just by letting off the gas? stopping at signs and lights?
if so, could be the Throttle Position Sensor (TPS) or it could be a small vacuum leak... check the plastic fittings in the vacuum lines and the duct from the air filter to the throttle body
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

yes like when stopping at signs/lights sometimes it will take off really fast
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
nobody important opined in

i think you should find someone to read out stored codes.... but it is very likely a vacuum leak... look for breaks of any kind, in vacuum lines or the tubing from the air filter and MAF.
still could be the TPS, though
tell you what, go to google and do a search on this group, you may find some similar problems .. even the solution may be apparent.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.