97 v6 taurus is running hot when in idle

Have replaced the themo. fush the rad. also any info would be helpful

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the fan working?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 20 Jun 2005 14:52:25 -0400, "babygirl21"

what the fock is it? h u r c a s t
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

97 Taurus with V6
y a
f o c k t a r d
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 20 Jun 2005 18:38:46 -0700, "Scott" <homealone.com> wrote:

ya foctard
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 20 Jun 2005 14:52:25 -0400, "babygirl21"

Does the electric fan come on when it is getting hot or with the air cond running? If not, you have a problem with the fan system. This could be a bad fan, control module, thermostatic switch, bad wiring or a loose connection. If it does not run hot driving down the road, it should not run hot at idle if the fan is working as it should. The fan will not work at idle with the a/c off unless the temperature rises. If the a/c is on, the fan should operate at idle.
Lugnut
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.