98 Windstar helluva rattle

My 98 Windstar / 94K miles has one helluva rattle that seems to be coming from the right front that's noticible mostly in bumpy parking lots. I don't
believe it's a bad strut, as I have full control of the vehicle, no slop in the steering.
I'd rather the front end not disintegrate while driving...can anyone offer what to look for? Maybe a common item that works loose on this model? I don't have a lift to pick it up unfortunately, though I could put it up on jackstands if necessary.
Oh, and thanks BY Mechanic for my previous post - IAC valve on the Taurus did the trick, and it was entirely too easy to replace. :-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GMach3 wrote:

Anti sway bar end link(s).
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GMach3 wrote:

If you have aluminum wheels, try removing the "starfish" wheel covers and see if the noise goes away. They're held on with a single ring that comes loose rather easily, causing the cover to rattle. I don't know what happens at highway speeds. I have lost three such wheel covers.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GMach3 wrote:

mounts for the stabilizer rods worked loose and rattled. There was some minor welding involved to reattach the sway bar mounts to the cradle under warranty. May have been a Recall, but it was likely a Campaign as it was not a safety issue. Not under warranty at this point anyway. Check where the front stabilizer rods connect to the subframe in the front of the vehicle.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.