98 Winstar door locks won't close and they run continuously

I have a 98 Windstar GL with 100K miles. We are the second owners and we've owned the veh since it had 17K miles.
About 2 weeks ago, the veh started to have a problem with the door
locks. When the veh would try to automatically lock the doors, the electric motors (that pull down the locks) would run and run and run, but the locks would not respond. The noise sounds like the veh is trying to lock the locks, but the locks don't move. And this is happening at the same time with several door locks in the vehicle!!
Usually we just push down the lock, and manually lock the door, and the elec. motor stops.
Today, our battery is dead. I opened both the doors, and in both doors (driver and passenger) I can hear a small the elec. motor running!! This is the elec motor that powers the elec locks, and it appears that this is what drained the veh battery!! And when I push the lock down, the elec motor does NOT stop.
Any idea what could cause this prob simultaneously in multiple locks?
What do I do?
What diagnostic tips can you give me?
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is a bad switch or relay someplace. The first thing I would do is look in your owner's manual and see what fuse the power goes through. And remove it. Otherwise, the motors may get too hot and cause a fire or burn out.
There are a few technical service bulletins for the elctrical system; one of them might apply to the truck. The other thing it could be a fault keyless entry thing or the recievers. I think this is unlikely, but it is possible.
Jeff

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jeff, Thanks for the advice. I did locate the fuse and pulled it. Now, how do I troubleshoot for a bad switch or relay? What do I do next?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

look
remove
one of

keyless
possible.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.