'99 Mercury Grand Marquis Rough Idle/Stalls

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


I have a '99 Grand Marquis recently it started have problems at idle.
Sometimes it idles but it feels like it is idling below its normal idle
speed. When driving it doesn't have a problem at any speed, however,
occasionally when cornering it will die.  The check engine light has not
come on (other than the normal times when starting or restarting).  I had
the codes checked anyway and as I expected I set a code of P1507 because I
have been keeping my foot on the accelerator to keep it from dieing at
idle.  Any suggestions would be greatly appreciated.


Re: '99 Mercury Grand Marquis Rough Idle/Stalls


On Sun, 11 Sep 2005 12:07:17 -0400, "lmcsween"

Quoted text here. Click to load it


IT sounds like tha IAC is dirty.  Many times they can be
cleaned and reinstalled after soaking in throttle body
cleaner for a while followed by a good spray dousing.  While
you are at it, it would be a good idea to clean the MAF
sensor and the EGR ports in the manifold.  The IAC will not
normally set a fault code just because it is dirty.  It can
also cause hard cold starts and no high idle when cold as it
should be.

Lugnut

Re: '99 Mercury Grand Marquis Rough Idle/Stalls


IAC valve.

Almost 100% sure. May be crapped up, may be shot. Just had exact same thing
last week on my Vette. Ran rough for a long time before it gave out. Pintle
all carboned up.

-GeorgeC

Quoted text here. Click to load it



Re: '99 Mercury Grand Marquis Rough Idle/Stalls


Im with these guys, had to clean it on my 98 CV and my 2000 GM.



wrote:

Quoted text here. Click to load it



--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail /

Site Timeline