99 sable transmission prob.

I have a 99 sable, standard 3L engine. 80,000 highway miles. When transmission hot I have a 1 to 2 shift problem. At low partial throttle (as leaving a light in heavy traffic) it sometimes shifts way too soon and
violently (chirps tires) then downshifts back to first with just a little more throttle. At moderate throttle everything works fine as when cold. Seems worst after driving on freeway. Fluid level is OK. Not predictable enough to take to dealer yet. Any ideas?????? Dealer wants $200 to power flush.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Change the filter and fluid first. See what happens.
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Skyhawk - I have a similar problem, and a flush did not help me. I would be interested in what else you find out.
Thanks -
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Skyhawk opined in

Do you have any other problems?
Like with the cold/hot idle speed?
Or return to idle at light?
Is your cruise control/speedo working well?
Try a google search on groups
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My problem may be a little different that Skyhawks. I have a very hard jerking/multiple hammering of the trans when shifting from 1st to 2nd. About the only time I can re-create the symptoms is after the car is well warmed up (15-20 miles), stopping at an intersection then accellerating normally and turning the corner at the same time. My mechanic checked it this AM and said there were no transmission codes. A flush and filters did not change anything. What does this bring to mind?
Thanks in advance -
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My problem may be a little different that Skyhawks. I have a very hard jerking/multiple hammering of the trans when shifting from 1st to 2nd. About the only time I can re-create the symptoms is after the car is well warmed up (15-20 miles), stopping at an intersection then accellerating normally and turning the corner at the same time. My mechanic checked it this AM and said there were no transmission codes. A flush and filters did not change anything. What does this bring to mind?
Thanks in advance -
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just an update on this - the transmission acted about the same for next day after the filter change. I drove it for short trips (< 10 miles) for two days, then drove it 40 miles a week after the filter and fluid change. The problem has not repeated as of a week later. Hopefully if there was dirt clogging a line it has broken loose. I will keep driving it and post if anything else happens. Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.