A Different Kind of FORD EXPLORER AC Problem...

I have a 2002 Ford Explorer, that had a very good ac two days ago, but now nothing comes out of the vents. I hear the compressor working when I turn it on, and hear it get louder as I turn up the ac. Though I can
feel cool air coming from the dashboard, nothing comes out of the vents.
HELP!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
akasoul wrote:

Maybe your blend doors have failed, in which case you should have air coming through your defrost vents. Designed for safety in the event of failure. Sometimes it is just a vacuum actuator arm that breaks, or a vacuum hose falls off. If it's under warranty take it to the dealer unless you want to hunt around behind the dash looking for the point of failure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Could it be the blower isnt working?
If it's the standard, knob-type speed control type, there's a resistor assy in the heater housing (under the dash, or under hood in some veh such as minivans) This is a flat plate that has several wires connected to it.
This often fails
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
akasoul wrote:

Sounds like your plenum diverter doors are not functioning. Is the cold air coming out the defroster nozzles... at the bottom of the windshield?
www.telstar-electronics.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.