A horn not working.

Hello !
Well I have a 1993 ford Areostar mini-van. About a year ago I replaed the horn as it was not working and it still is not working. I just had some time
to check the inside and the horn relay wass clicking when I press the horn button. So I figured it could be that, but after I replaced it with a new one the relay still clicks when I push the horn button.
When I did replace the horn it was one of them horns that requires the (-) be looped to the back of the unit.
The new horn relay when I did buy it I had the person check twice to make sure it was the right one.
Also from check I have seen post in different sites like a UK site that says something about the airbag not working that will cause the horn not to work.
I do not know if this makes sence, but the airbag light is also in a 3 blink mode. Clinks 3 times then stops for a few secons and then blinks 3 more times.
I do not want to do a hugh job on this thing, but the only thing I can think of is either it is the the airbag thing, or maybe there is like 2 relays and would not make sence.
Any help would be welcomed as I am getting mis-info from the people at like autozone and techs at repair shops taht want a bit of money to find the cause and I dont want to pay like $50 or more just to find the reason it is not working.
Thanks in advance !
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
MagicTime wrote:

Sounds like the clock spring in the steering wheel, which provides electrical continuity for the horn, SRS airbag, and cruise control. If you're going to keep the vehicle, INVEST in the Factory Service Manual & EVTM for it. Look on eBay or go to the manual's publishing source at www.helminc.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

holy cow man, try to just use a test light and find out where the juice is. your jumping all over the place guessing instead of simple testing. KB
--
Thunder Snake #9
"Protect" your rights or "lose" them.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.