battery bad cell?????

i have a 96 windstar and the battery has developed a pattern of going dead after charging about every 7 to 9 days,i know some are going to say it's a short draining the battery but the odd thing about this is-when the battery
goes dead,there is no slow starting or slowing of the starter to indicate the battery is getting low or weak,all of a sudden you go to start it and boom it's dead,jump it and first try it starts right up,it will last a couple more times if i don't charge it ,then simply by a jump it starts,if i put a 3-4 hour charge in it,it will last 7-9 days before this pattern happens again.i have a dayton mobile charger with guages and i don't know how accurate they are but when i put a medium charge into it , the amperage guage is extremely low(below 10) and the voltage guage is around (14 to 18). can anyone tell me if these are symptoms of a a bad battery(cell) alternator or a drain????????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

it to make sure. You could just take it to a battery place, they would most likely check the alt and battery for free.
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The symptoms sound like corroded battery terminals to me. Remove them, clean both sides well and reassemble. I suspect the problem will go away.
PoD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
your battery is bad. they only last 4-5 years.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.