Check Eng Light on only when I accelerate - Help

Hi, I have been getting a Check Engine Light only when I accelerate when I drive, once I let off the gas the light goes out. Any thoughts on where
to start troubleshooting - The car is old 88 t-bird V8 169K miles - I really don't notice any serious issues caused from it, I am thinking it may be a pressure issue, like a vacuum leak or fuel injection problem. Your thoughts??? Thanks, Tony
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

probably egr related; once you get the charging prob fixed have the codes read out.
--
Yeh, I'm a Krusty old Geezer, staving off dementia here..DEAL with it!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"kojmorbid" wrote

If you have a little piece of wire, you can check the codes yourself...
http://www3.telus.net/neatcrap/eec4.gif
The connectors are on the driver's side, by the strut tower.
Hook up the wire, get in, turn the key to "on" (not start) and count the flashes.
Here's a car with code 23 "now" and 46 "continuous" (in memory).....
******.......*.*...*.*.*.....*.*....*.*.*.........*..........*.*.*.*....*.*.*.*.*.*.....*.*.*.*....*.*.*.*.*.*
Ignore initial flashing, 2, 3, pause, 2, 3, big pause, 1, big pause, 4, 6, pause, 4, 6
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.