Dragging parking Brake like noise -2005 Explorer

I just replaced the rear disc brakes, rotor and parking brakes in my 2005 Ford Explorer. The rear parking brake is the hat style which the parking brake is within the rotor for the disc brake. The problem is
that I can not stop the sound of which is the parking brake dragging. I gained access to the star wheel and backed off to the point that I can slide the rotors over the parking brake. But no matter what I do the parking brake drags. I replace the spring clips on the parking brakes but still no success. I've drive about with the brakes dragging to wear in but no success. I checked the ID of the rotors and are OK????? I can not be the only home mechanic with this problem. What am I missing
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In article < snipped-for-privacy@b64g2000hsa.googlegroups.co m>,

There are known cases of aftermarket rotors hitting the backing plate at the edge of the parking brake drum. i.e., the drum portion is a wee bit too deep. Make sure that isn't what's happening. You may see scrape marks on the rotor but not on the backing plate.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.