Ford Escape Key Programming Problem

I just got a 3rd key for my ford escape and I am trying to program it. I go through the steps in the manual, but it does not work! Does anyone know if I am doing something wrong, or any tips for me on what to do?
Here is the basic steps I follow: Insert 1st programmed key and turn it from 1 (off) to 3 - I leave it for a second, or two and turn if off. Insert 2nd programmed key and turn it from 1 (off) to 3 - I leave it again for a second or two and turn if off. I insert the 3rd unprogrammed key and turn it from 1 (off) to 3 - I leave it for a second, and turn if off.
I try to start it, but the theft light flashes. I have even tried leaving it in for 5 seconds, but still no go. When switching keys I try to do it as fast as I can.
Any suggestions?
Thanks! ~Rich
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I usually turn the key to run and leave it until the theft life proves out..... do the same with the second... the third key I leave for about 5 seconds before....
If this method refuses to work, it is possible that the "spare key programming switch" in the PATS security programming is not enabled.... To enable this feature, a scan tool capable of communicating with proprietary modules will be required.... Once security access procedures have been initiated, it will take ten minutes to access security programming...
HTH

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I tried your method, but it still does not work. :-( I just had it in for servicing to make an extra key to give me the ability to do this, so I don't know why it wouldn't work. I guess they didn't enable that feature then... I'll have to give them a call and find out why they didn't enable that feature you mentioned.
Thank anyway. ~Rich
Jim Warman wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try this,
Start with 1st key, second key, 3th new key, finish with 1st key Wait till light goes out with every key
I remember there was a catch in sequence, cant remember what :-( sucks getting old

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.