Ford Escort clicking/creaking noise.

Hi,
I have a 1999 Ford Escort 1.6 which has recently developed a clicking/ creaking sound.
It started yesterday, and after leaving over night and driving a
couple of short runs this morning the noise had vanished. Phew I thought.
After a 30 mile run this noon the noise came back. It seems to creak when pulling away from being stopped. Then randomly grates and creaks in transit. Haven't noticed it at higher speeds, over 30MPH.
Again the car was left for a couple of hours and on driving it again this evening briefly the noise is gone.
Any ideas, it's obviously going to come back again after a long run?
Have forced suspension down but doesn't appear to be that, nothing appears dislodged or hanging off in the engine bay or underneath the car.
Any advice would be appreciated.
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How do the brakes feel? Remember the pads are in contact with the discs all the time. Does the sound change when you step on and let off the brake?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The hand brake cable is infamous for rusting up and sticking not releasing completely. Also, does it go to the rhythm of your tach? If you have one, and the needle is boincing in tune with the noise, the tach cable could use regreasing/replacing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.